$re = '~document/([-\w]+)~';
$str = 'This is the paragraph which also contains link http://example.com/document/EN010001-0001, now this is some text after the link';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);