const regex = new RegExp('document/([-\\w]+)', '')
const str = `This is the paragraph which also contains link http://example.com/document/EN010001-0001, now this is some text after the link`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}