using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)[#]\w\S*(?=<)\b";
string input = @"<p></p><p>#clarity is what I want</p><p></p><p>#bootiful #dreamer</p><p><a href=""https://arstechnica.com/gadgets/2020/05/caddy-offers-tls-https-and-more-in-one-dependency-free-go-web-server/#first"" rel=""noopener noreferrer nofollow"">https://arstechnica.com/gadgets/2020/05/caddy-offers-tls-https-and-more-in-one-dependency-free-go-web-server/#first</a></p
<span class=""hashtag"" data-hashtag-id=""dreamer"">#dreamer</span>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}