const regex = /(?<=>)[#]\w\S*(?=<)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=>)[#]\\w\\S*(?=<)\\b', 'g')
const str = `<p></p><p>#clarity is what I want</p><p></p><p>#bootiful #dreamer</p><p><a href="https://arstechnica.com/gadgets/2020/05/caddy-offers-tls-https-and-more-in-one-dependency-free-go-web-server/#first" rel="noopener noreferrer nofollow">https://arstechnica.com/gadgets/2020/05/caddy-offers-tls-https-and-more-in-one-dependency-free-go-web-server/#first</a></p
<span class="hashtag" data-hashtag-id="dreamer">#dreamer</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}