import re
regex = re.compile(r"(?<=>)[#]\w\S*(?=<)\b")
test_str = ("<p></p><p>#clarity is what I want</p><p></p><p>#bootiful #dreamer</p><p><a href=\"https://arstechnica.com/gadgets/2020/05/caddy-offers-tls-https-and-more-in-one-dependency-free-go-web-server/#first\" rel=\"noopener noreferrer nofollow\">https://arstechnica.com/gadgets/2020/05/caddy-offers-tls-https-and-more-in-one-dependency-free-go-web-server/#first</a></p\n\n"
"<span class=\"hashtag\" data-hashtag-id=\"dreamer\">#dreamer</span>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")