import Foundation
let pattern = ##"(?<=>)[#]\w\S*(?=<)\b"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<p></p><p>#clarity is what I want</p><p></p><p>#bootiful #dreamer</p><p><a href="https://arstechnica.com/gadgets/2020/05/caddy-offers-tls-https-and-more-in-one-dependency-free-go-web-server/#first" rel="noopener noreferrer nofollow">https://arstechnica.com/gadgets/2020/05/caddy-offers-tls-https-and-more-in-one-dependency-free-go-web-server/#first</a></p
<span class="hashtag" data-hashtag-id="dreamer">#dreamer</span>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)