package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+(?:-\d+)?\s*(M{0,4}(?:C[MD]|D?C{0,3})(?:X[CL]|L?X{0,3})(?:I[XV]|V?I{0,3})))\.\s*(.*)`)
var str = `05-21 I. Don Quixote
21-20 IV. Macbeth
10-12 ML. To Kill a Mockingbird
12 V. Invisible Man`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}