const regex = new RegExp('^(\\d+(?:-\\d+)?\\s*(M{0,4}(?:C[MD]|D?C{0,3})(?:X[CL]|L?X{0,3})(?:I[XV]|V?I{0,3})))\\.\\s*(.*)', 'gm')
const str = `05-21 I. Don Quixote
21-20 IV. Macbeth
10-12 ML. To Kill a Mockingbird
12 V. Invisible Man`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}