re = /^(\d+(?:-\d+)?\s*(M{0,4}(?:C[MD]|D?C{0,3})(?:X[CL]|L?X{0,3})(?:I[XV]|V?I{0,3})))\.\s*(.*)/m
str = '05-21 I. Don Quixote
21-20 IV. Macbeth
10-12 ML. To Kill a Mockingbird
12 V. Invisible Man'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end