import re
regex = re.compile(r"^(\d+(?:-\d+)?\s*(M{0,4}(?:C[MD]|D?C{0,3})(?:X[CL]|L?X{0,3})(?:I[XV]|V?I{0,3})))\.\s*(.*)", flags=re.MULTILINE)
test_str = ("05-21 I. Don Quixote\n"
"21-20 IV. Macbeth\n"
"10-12 ML. To Kill a Mockingbird\n"
"12 V. Invisible Man")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")