using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[Vv]\d{2}\.*\d{1,2}$)|(^[Ee]\d{3}\.*\d{0,1}$)|(^\d{2,4}$)|(^\d{2}\.*\d{1,2}$)";
string input = @"E8015";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}