re = /(^[Vv]\d{2}\.*\d{1,2}$)|(^[Ee]\d{3}\.*\d{0,1}$)|(^\d{2,4}$)|(^\d{2}\.*\d{1,2}$)/
str = 'E8015'
# Print the match result
str.match(re) do |match|
puts match.to_s
end