package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[Vv]\d{2}\.*\d{1,2}$)|(^[Ee]\d{3}\.*\d{0,1}$)|(^\d{2,4}$)|(^\d{2}\.*\d{1,2}$)`)
var str = `E8015`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}