const regex = /.\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.\\n', 'gm')
const str = `src\\Gpac\\gpac.exe -i pipe://video:ext=hevc:audelim=true -o stdout:ext=ts:pes_pack=none | src\\FFmpeg\\ffmpeg_win_x64.exe -hide_banner -y -i - -i I:\\BDMV\\STREAM\\00018.m2ts -map 0:0 -map 1:2 -c copy -bsf:v hevc_metadata=aud=insert -metadata title=
"Transformers_____________________________________"
D:\\Transformers.mkv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}