# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".\n"
test_str = ("src\\Gpac\\gpac.exe -i pipe://video:ext=hevc:audelim=true -o stdout:ext=ts:pes_pack=none | src\\FFmpeg\\ffmpeg_win_x64.exe -hide_banner -y -i - -i I:\\BDMV\\STREAM\\00018.m2ts -map 0:0 -map 1:2 -c copy -bsf:v hevc_metadata=aud=insert -metadata title=\n"
"\"Transformers_____________________________________\"\n"
"D:\\Transformers.mkv")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.