re = /.\n/m
str = 'src\\Gpac\\gpac.exe -i pipe://video:ext=hevc:audelim=true -o stdout:ext=ts:pes_pack=none | src\\FFmpeg\\ffmpeg_win_x64.exe -hide_banner -y -i - -i I:\\BDMV\\STREAM\\00018.m2ts -map 0:0 -map 1:2 -c copy -bsf:v hevc_metadata=aud=insert -metadata title=
"Transformers_____________________________________"
D:\\Transformers.mkv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end