import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,5}(?!\\d+)[-\\p{L}\\d]+$";
final String string = "12345a235\n"
+ "123a\n"
+ "12345-aa1\n"
+ "12345a\n"
+ "12345-a\n\n"
+ "-11\n"
+ "111111\n"
+ "aaaa\n\n\n\n"
+ "version 1 :: plain ... ^\\d{1,5}(?!\\d+)[-\\p{L}\\d]+$\n"
+ "version 2 :: named ... ^(?<digitsOnly>\\p{N}{1,5}(?!\\p{N}+))(?<miscellaneous>[-\\p{L}\\p{N}]+)$\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}