$re = '/^\d{1,5}(?!\d+)[-\p{L}\d]+$/mu';
$str = '12345a235
123a
12345-aa1
12345a
12345-a
-11
111111
aaaa
version 1 :: plain ... ^\\d{1,5}(?!\\d+)[-\\p{L}\\d]+$
version 2 :: named ... ^(?<digitsOnly>\\p{N}{1,5}(?!\\p{N}+))(?<miscellaneous>[-\\p{L}\\p{N}]+)$
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);