import re
regex = re.compile(r"^\d{1,5}(?!\d+)[-\p{L}\d]+$", flags=re.MULTILINE | re.UNICODE)
test_str = ("12345a235\n"
"123a\n"
"12345-aa1\n"
"12345a\n"
"12345-a\n\n"
"-11\n"
"111111\n"
"aaaa\n\n\n\n"
"version 1 :: plain ... ^\\d{1,5}(?!\\d+)[-\\p{L}\\d]+$\n"
"version 2 :: named ... ^(?<digitsOnly>\\p{N}{1,5}(?!\\p{N}+))(?<miscellaneous>[-\\p{L}\\p{N}]+)$\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")