use strict;
my $str = '12345a235
123a
12345-aa1
12345a
12345-a
12-a235dkfsf
12-a235dkfsfs
123a-dssava-y
123a-dssava-1a
12345-aa1--asd-
12345-aa1--asd-s
-11
111111
aaaa
version 1 :: plain ... ^\\d{1,5}[-\\p{L}][-\\p{L}\\d]{0,9}$
version 2 :: named ... ^(?<digitsOnly>\\p{N}{1,5})(?<miscellaneous>[-\\p{L}][-\\p{L}\\p{N}]{0,9})$
';
my $regex = qr/^\d{1,5}[-\p{L}][-\p{L}\d]{0,9}$/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}