# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{1,5}[-\p{L}][-\p{L}\d]{0,9}$"
test_str = ("12345a235\n"
"123a\n"
"12345-aa1\n"
"12345a\n"
"12345-a\n\n"
"12-a235dkfsf\n"
"12-a235dkfsfs\n\n"
"123a-dssava-y\n"
"123a-dssava-1a\n\n"
"12345-aa1--asd-\n"
"12345-aa1--asd-s\n\n"
"-11\n"
"111111\n"
"aaaa\n\n\n\n"
"version 1 :: plain ... ^\\d{1,5}[-\\p{L}][-\\p{L}\\d]{0,9}$\n"
"version 2 :: named ... ^(?<digitsOnly>\\p{N}{1,5})(?<miscellaneous>[-\\p{L}][-\\p{L}\\p{N}]{0,9})$\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.