package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)fa-[a-zA-Z0-9-]+`)
var str = `fa
fa-
battery
fa-battery
fa-battery hello
fa-battery!
fabattery
fa-battery-empty
fa-battery_empty
fa-battery-2
fa-battery\
fa-battery \
fa-battery\\
fa-2x`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}