$re = '/fa-[a-zA-Z0-9-]+/m';
$str = 'fa
fa-
battery
fa-battery
fa-battery hello
fa-battery!
fabattery
fa-battery-empty
fa-battery_empty
fa-battery-2
fa-battery\\
fa-battery \\
fa-battery\\\\
fa-2x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);