// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)fa-[a-zA-Z0-9-]+").unwrap();
let string = "fa
fa-
battery
fa-battery
fa-battery hello
fa-battery!
fabattery
fa-battery-empty
fa-battery_empty
fa-battery-2
fa-battery\\
fa-battery \\
fa-battery\\\\
fa-2x";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}