use strict;
my $str = 'fa
fa-
battery
fa-battery
fa-battery hello
fa-battery!
fabattery
fa-battery-empty
fa-battery_empty
fa-battery-2
fa-battery\\
fa-battery \\
fa-battery\\\\
fa-2x';
my $regex = qr/fa-[a-zA-Z0-9-]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}