#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "('+)([\w/-]+)\1"
Local $sString = "l''''text'''"
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)