import re
regex = re.compile(r"('+)([\w/-]+)\1")
test_str = "l''''text'''"
subst = "\\2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)