$re = '/(\'+)([\w/-]+)\1/';
$str = 'l\'\'\'\'text\'\'\'';
$subst = "\2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;