const regex = new RegExp('(\\'+)([\\w/-]+)\\1', '')
const str = `l''''text'''`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);