$re = '/(?:([^\[]+)\[([^\]]+)\])/';
$str = '/foo/firstName[firstId]/optional1[oId1]/optional2[oId2]/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);