re = /(?:([^\[]+)\[([^\]]+)\])/
str = '/foo/firstName[firstId]/optional1[oId1]/optional2[oId2]/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end