const regex = /<!-- InstanceBeginEditable name="cat" -->(.*)<!-- InstanceEndEditable -->/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!-- InstanceBeginEditable name="cat" -->(.*)<!-- InstanceEndEditable -->', '')
const str = `<!-- InstanceBeginEditable name="cat" -->Properties of Matter <!-- InstanceEndEditable -->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}