$re = '/<!-- InstanceBeginEditable name="cat" -->(.*)<!-- InstanceEndEditable -->/';
$str = '<!-- InstanceBeginEditable name="cat" -->Properties of Matter <!-- InstanceEndEditable -->';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);