re = /<!-- InstanceBeginEditable name="cat" -->(.*)<!-- InstanceEndEditable -->/
str = '<!-- InstanceBeginEditable name="cat" -->Properties of Matter <!-- InstanceEndEditable -->'
# Print the match result
str.match(re) do |match|
puts match.to_s
end