#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(\d+),\s+([^\u4e00-\u9fff]+)(.+)$"
Local $sString = "1, 05B01北京企商联登记注册代理事务所(通合伙)" & @CRLF & _
"2, Unit-D 608华夏启商(北京企业管理有限公司)" & @CRLF & _
"3, 1004-1005北京中睿智诚商业管理有限公司" & @CRLF & _
"4, 17/F(1706)北京美泰德商务咨询有限公司" & @CRLF & _
"5, A2006~A2007北京新曙光会计服务有限公司" & @CRLF & _
"6, 2906-10中国建筑与室内设计师网'''"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")