import re
regex = re.compile(r"^(\d+),\s+([^\u4e00-\u9fff]+)(.+)$", flags=re.MULTILINE | re.UNICODE)
test_str = ("1, 05B01北京企商联登记注册代理事务所(通合伙)\n"
"2, Unit-D 608华夏启商(北京企业管理有限公司)\n"
"3, 1004-1005北京中睿智诚商业管理有限公司\n"
"4, 17/F(1706)北京美泰德商务咨询有限公司\n"
"5, A2006~A2007北京新曙光会计服务有限公司\n"
"6, 2906-10中国建筑与室内设计师网'''")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")