// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^(\d+),\s+([^\u4e00-\u9fff]+)(.+)$").unwrap();
let string = "1, 05B01北京企商联登记注册代理事务所(通合伙)
2, Unit-D 608华夏启商(北京企业管理有限公司)
3, 1004-1005北京中睿智诚商业管理有限公司
4, 17/F(1706)北京美泰德商务咨询有限公司
5, A2006~A2007北京新曙光会计服务有限公司
6, 2906-10中国建筑与室内设计师网'''";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}