import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+),\\s+([^\\u4e00-\\u9fff]+)(.+)$";
final String string = "1, 05B01北京企商联登记注册代理事务所(通合伙)\n"
+ "2, Unit-D 608华夏启商(北京企业管理有限公司)\n"
+ "3, 1004-1005北京中睿智诚商业管理有限公司\n"
+ "4, 17/F(1706)北京美泰德商务咨询有限公司\n"
+ "5, A2006~A2007北京新曙光会计服务有限公司\n"
+ "6, 2906-10中国建筑与室内设计师网'''";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}