#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*<\/?tag>|(.+)$"
Local $sString = "<tag>" & @CRLF & _
" <tag>" & @CRLF & _
" <tag>" & @CRLF & _
" <i> abcd </i>" & @CRLF & _
" </tag>" & @CRLF & _
" </tag>" & @CRLF & _
"</tag>" & @CRLF & _
"" & @CRLF & _
"<tag>" & @CRLF & _
" <tag>" & @CRLF & _
" efgh" & @CRLF & _
" </tag>" & @CRLF & _
"</tag>" & @CRLF & _
"" & @CRLF & _
"<tag>" & @CRLF & _
" ijkl" & @CRLF & _
"</tag>" & @CRLF & _
"" & @CRLF & _
"<tag>" & @CRLF & _
" mnop" & @CRLF & _
"</tag>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")