$re = '/.*<\/?tag>|(.+)$/m';
$str = '<tag>
<tag>
<tag>
<i> abcd </i>
</tag>
</tag>
</tag>
<tag>
<tag>
efgh
</tag>
</tag>
<tag>
ijkl
</tag>
<tag>
mnop
</tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);