re = /.*<\/?tag>|(.+)$/m
str = '<tag>
<tag>
<tag>
<i> abcd </i>
</tag>
</tag>
</tag>
<tag>
<tag>
efgh
</tag>
</tag>
<tag>
ijkl
</tag>
<tag>
mnop
</tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end