import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*<\\/?tag>|(.+)$";
final String string = "<tag>\n"
+ " <tag>\n"
+ " <tag>\n"
+ " <i> abcd </i>\n"
+ " </tag>\n"
+ " </tag>\n"
+ "</tag>\n\n"
+ "<tag>\n"
+ " <tag>\n"
+ " efgh\n"
+ " </tag>\n"
+ "</tag>\n\n"
+ "<tag>\n"
+ " ijkl\n"
+ "</tag>\n\n"
+ "<tag>\n"
+ " mnop\n"
+ "</tag>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}