using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Subject:)(.*)(.{2})$";
string substitution = @"$1$2";
string input = @"Subject: =?windows-1252?B?VGhpcyBpcyB0aGUgb3JpZ2luYWwgc3ViamVjdA==?=";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}