import re
regex = re.compile(r"^(Subject:)(.*)(.{2})$")
test_str = "Subject: =?windows-1252?B?VGhpcyBpcyB0aGUgb3JpZ2luYWwgc3ViamVjdA==?="
subst = "$1$2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)