re = /^(Subject:)(.*)(.{2})$/
str = 'Subject: =?windows-1252?B?VGhpcyBpcyB0aGUgb3JpZ2luYWwgc3ViamVjdA==?='
subst = '$1$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result