$re = '/^(Subject:)(.*)(.{2})$/';
$str = 'Subject: =?windows-1252?B?VGhpcyBpcyB0aGUgb3JpZ2luYWwgc3ViamVjdA==?=';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;