# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/tree(?=(?:(?:[^"]*"){2})*[^"]*$)/pizza/gm;t' <<< "The tree is green. -> REPLACE \"tree\" WITH pizza
\"The\" tree is \"green\". -> REPLACE \"tree\" WITH pizza
\"The tree\" is green. -> DONT REPLACE
\"The tree is\" green. -> DONT REPLACE
The \"\"tree is green. -> REPLACE \"tree\" WITH pizza"