import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "tree(?=(?:(?:[^\"]*\"){2})*[^\"]*$)";
final String string = "The tree is green. -> REPLACE \"tree\" WITH pizza\n"
+ "\"The\" tree is \"green\". -> REPLACE \"tree\" WITH pizza\n"
+ "\"The tree\" is green. -> DONT REPLACE\n"
+ "\"The tree is\" green. -> DONT REPLACE\n"
+ "The \"\"tree is green. -> REPLACE \"tree\" WITH pizza";
final String subst = "pizza";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}