$re = '/tree(?=(?:(?:[^"]*"){2})*[^"]*$)/m';
$str = 'The tree is green. -> REPLACE "tree" WITH pizza
"The" tree is "green". -> REPLACE "tree" WITH pizza
"The tree" is green. -> DONT REPLACE
"The tree is" green. -> DONT REPLACE
The ""tree is green. -> REPLACE "tree" WITH pizza';
$subst = "pizza";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;