import re
regex = re.compile(r"tree(?=(?:(?:[^\"]*\"){2})*[^\"]*$)", flags=re.MULTILINE)
test_str = ("The tree is green. -> REPLACE \"tree\" WITH pizza\n"
"\"The\" tree is \"green\". -> REPLACE \"tree\" WITH pizza\n"
"\"The tree\" is green. -> DONT REPLACE\n"
"\"The tree is\" green. -> DONT REPLACE\n"
"The \"\"tree is green. -> REPLACE \"tree\" WITH pizza")
subst = "pizza"
result = regex.sub(subst, test_str)
if result:
print(result)